# DVDStyler Operators Manual, Program Version 1.5

## Table of Contents

Overview ........................................................................................................................................... 2
Requirements .................................................................................................................................. 2
License ............................................................................................................................................ 2
Installation instructions (Windows 2000 / XP) ........................................................................... 3
Guide ............................................................................................................................................... 3

- Create a new project .................................................................................................................. 3
- Select a movie clip ....................................................................................................................... 3
- Create a menu ............................................................................................................................. 4
- Save the project ........................................................................................................................... 5
- Render the project ....................................................................................................................... 5

Program features .......................................................................................................................... 7

- Program Menu Selections ........................................................................................................... 7
- Menu Properties .......................................................................................................................... 9
- Menu Creation Tools .................................................................................................................. 11
- Title Properties .......................................................................................................................... 26

Audio / Video Properties ........................................................................................................... 27

Setting menu background color ................................................................................................. 31

Setting menu background image ................................................................................................. 31

Configuring “Enter”, “Up”, “Down”, “Left”, “Right” button actions ........................................ 32

Setting-up chapter points ........................................................................................................... 34

Miscellaneous speed menus and buttons .................................................................................... 36

Creating multiple menus (single titleset) ................................................................................... 38

- Creating the menus .................................................................................................................... 38
- Selecting movie clips ................................................................................................................... 40
- Applying buttons to the menus .................................................................................................. 40
- Adding buttons to the menus ...................................................................................................... 40

Using a video clip on the menu background ............................................................................ 43

- Creating a menu with video ........................................................................................................ 43

Using elemental streams ............................................................................................................. 44

- Elemental streams – What is multiplexing? ............................................................................. 44
- Elemental streams – What are the components? ....................................................................... 45

Creating a title with elemental streams ..................................................................................... 45

Multiple Titlesets .......................................................................................................................... 46

- Titlesets – A word of caution .................................................................................................. 46
- Titlesets – Why do we need them? ......................................................................................... 46
- Titlesets – What are they? .......................................................................................................... 47
- Titlesets – A word about aspect ratios .................................................................................... 47

Titlesets – vmMenu versus Menu (or VMG menu versus VTS menu) ........................................ 48

Titlesets – The project XML file ................................................................................................. 49

Titlesets – Creating a multi-titleset menu .................................................................................... 49

General Notes, Menu Creation Tips, and Known Issues ............................................................ 53

Authors and links ......................................................................................................................... 57
Overview

DvdStyler is a cross-platform DVD menu creation GUI that allows the user to create DVD navigation menus similar to those found on most commercial DVDs. It leverages various other open source video rendering programs to produce the final DVD menu navigation system. DvdStyler is an open source program that has been developed with the Linux operating system and is supported on the Windows environment (see “Requirements” for platform support).

Note - At the time of this writing, the program has been shown to operate well on Windows-2000 and Windows-XP. It does not however do well with Windows-98. The developer(s) are currently attempting to resolve those issues.

Requirements

Linux distribution – The DvdStyler program requires various support program be installed that are not provided with this distribution. Please visit the websites of each program distribution for downloads, documentation, and installation details.

1. wxGTK-2.6
2. DvdAuthor
3. MJPEG Tools
4. MPEG toolbox (mpgtx)
5. Xine multimedia player (optional, for preview)
   a. http://xinehq.de/
6. Totem movie player (optional, for generation of thumbnails)

Windows distribution – No additional libraries are required beyond those provided by the operating system and the DvdStyler installation program.

License

DvdStyler is free software (http://www.gnu.org/philosophy/free-sw.html) distributed under GNU General Public License (GPL – http://www.gnu.org/copyleft/gpl.html). Please visit those sites for details of each agreement.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
Installation instructions (Windows 2000 / XP)

DVDStyler is provided with an automatic installation system. You can simply follow the provided prompts to install the program.

During rendering, you will be prompted to select temporary and final output directories. You can use the default locations or change to the directories of your choice. This manual uses the directories described below:

1. Optional - Manually create a temporary directory for rendering.
   a. This tutorial uses “C:\Program Files\DVDStyler\Temp1”.
   b. Temporary files are automatically deleted after rendering.
   c. DVD movie files (AUDIO_TS AND VIDEO_TS) will be written here.
   d. Note – During the rendering process, if you enter this directory manually, and it does not already exist, the program will create it automatically.

2. Optional - Manually create a final directory for rendered movies.
   a. This tutorial uses “C:\Program Files\DVDStyler\Temp2”.
   b. DVD “iso” image files will be written here.
   c. Note – During the rendering process, if you enter this directory manually, and it does not already exist, the program will create it automatically.

3. Optional - Manually create a log directory for logged messages.
   a. This tutorial uses “C:\Program Files\DVDStyler\Log\Mylog.txt”.
   b. Note - The typical user does not need to create this directory or enter it into the Configuration -> Settings -> Log File field. It is meant for debugging.

Guide

This tutorial presents the shortest possible path to creating a DVD menu. It is limited to a single movie clip, a single menu selection, and virtually no modifications to the default selections.

Create a new project

1. Start the DVDStyler program, then start a new project by:
   a. Click File -> New. The program will prompt you to select a movie format. Select PAL or NTSC, as desired.
   b. Note - See “Configuration -> Settings -> Default Menu Format” for additional details on these selections.

Select a movie clip

1. Click on the “Directories” tab on the left side of the program window.
2. Navigate-to and highlight the directory that contains your movie clip(s). An icon for each clip will be presented in the top-center panel.
3. Drag the desired movie clip (left-click, hold, and drag) onto the project timeline panel at the bottom of the program window.

Create a menu

1. Click the “Backgrounds” tab on the left side of the program window.
2. Select a menu background image by double-clicking on an image in the “Backgrounds” panel.
3. Note – See “Advanced Features / Setting Menu Background Image” for further information on background images.
4. Click on the “Buttons” tab on the left-hand edge of the program window.
5. Insert a button by dragging (left-click, hold, and drag) a button name into the Menu Editing Panel. With the provided handles, re-position the button as desired.
6. Edit the button properties (name, color, font, etc) by right clicking on the button in the Menu Editing panel (place the mouse pointer over the button and right-click). From the speed-menu select “Properties” to access the menu. Change various properties as desired. When finished, click “OK” to return to the Menu Editing Panel.

Save the project

1. A very basic menu has now been configured. Now is a good time the save the project. Save it by selecting “File”, “Save As”, and select a directory and name for your saved project.

Render the project

1. Select “File” then “Burn DVD…”
2. From the “Burn” dialogue select an appropriate directory for “Temporary directory.” Use the directory created during the installation instructions. DVDStyler will automatically append the “DVD” subdirectory to your selection.
3. Check the box for “create iso image”.
4. From the “Burn” dialogue select an appropriate directory for “Save to:” Use the directory created during the installation instructions. DVDStyler will automatically write the “dvd.iso” image file to your selection.
5. Click “Start” to render the movie. The rendering status will be displayed with its associated messages. The final “iso” burn image file will be written to the directory selected in step D above.

7. Burn your finished DVD with the desired burning software.

8. Note – The burn selections are currently supported only in the Linux distribution of DVDStyler.
Program features

Program Menu Selections

This section describes each selection of each menu. Some selections are currently not implemented. See the “General Notes, Menu Creation Tips, and Known Issues” section at the end of this manual for special tips and instructions.

File

1. **New**
   a. Select “File -> New” to create a new DVD project. Any existing project work will be prompted for saving before opening a new project.

2. **Open**
   a. Select “File -> Open” to load a saved DVD project.

3. **Save**
   a. Select “File -> Save” to save a project.
   b. All project configurations will be saved in an “XML” file that defines movie clips, chapters, menus, buttons, and various other selections.
   c. Note – The project must be named with the “Save as” selection. If it has not already been saved, the “Save as” dialogue will be presented.

4. **Save as**
   a. Select “File -> Save as” to name and save your DVD project.
   b. Navigate to an appropriate directory to save the project and enter a project file name.
   c. The default project file name is “dvd.xml”.

5. **Burn DVD**
   a. Select “Burn DVD” to render your project.
   b. At least one clip must be assigned to the project timeline prior to rendering a project. The burn dialogue will be presented.
   c. Click the file navigation button (square button to the right of the Temp directory field) to select an appropriate temporary directory. Temporary rendering file will be automatically deleted after the final files have been processed.
   d. Create iso image check box
      i. Check the “create iso image” box to render the project into a burn-able DVD image.
      ii. Uncheck the “create iso image” box to render the project into discrete DVD files (AUDIO_TS AND VIDEO_TS directories).
   e. Click the file navigation button (square button to the right of the “Save to” field) to select an appropriate final project file location. Your DVD image file (iso) will be written here.
   f. Note – If you un-check “create iso image”, the discrete DVD files will be written to the “Temp directory” location.

6. **Exit**
   a. Click “File -> Exit” to exit the DVDSstyler program. Any existing project work will be prompted for saving prior to exiting.
**Configuration - > Settings**

DVDStyler executes several processes during rendering (converts menu background images into short jpeg clips, de-multiplexes clips into their elemental streams (audio and video), re-multiplexes, and various other processes). The program provides access to these settings in order to customize the finished product to your liking. Although most of the settings are appropriate for most movies, but you may wish to make modifications to meet your needs.

**Note** – If you make changes and wish to undo the changes, click the reset button to restore all setting to their default settings.

1. **Language**
   2. Select the desired language by clicking the down-arrow control at the right-hand side of the “Language” field.
   3. Language selections will be executed after the DVDStyler program has been exited and re-started.
   4. **Note** – See “General Notes, Menu Creation Tips, and Known Issues” if you experience difficulty in changing the language selection.

5. **Default menu format**
   a. Select the desired default menu format (PAL or NTSC) for new menus.
   b. When selecting “File -> New” this format will be used to size the menu.
   c. PAL (720 X 576) is usually used in European countries.
   d. NTSC (720 X 480) is usually used in North America and several other countries.
   e. **Note** - The menu format for your project may be modified by: Right click in the Menu Editing Panel to access its speed menu. Select properties. From the properties menu select the desired format (PAL or NTSC). Click “OK” to accept. The Menu Editing Panel will automatically adjust to the selected format.

1) **Log file**
   a. Enter a drive, directory, and file name to log rendering messages.
   f. This tutorial uses “C:\Program Files\DVDStyler\Log\Mylog.txt”.
   g. Using the message log is optional. If you do not care to have a message log, make sure this field is completely blank. This field is meant for debugging.
   h. Log file message are currently unsupported.

2) **Jpeg2Mpeg command**
   i. This is the syntax that DVDStyler uses to pass commands to the “jpeg2yuv” command of DvdAuthor. It converts the image(s) used in menu backgrounds into short Mpeg clips used on the DVD menu.
   j. DVDStyler supports JPEG, BMP, PNG, and various other image formats.

3) **Frame rate PAL**
   k. This is the frame rate DVDStyler uses when render a project in the PAL video format.
   l. The PAL default frame rate is 25 frames per second.

4) **Frame rate NTSC**
   m. This is the frame rate DVDStyler uses when render a project in the NTSC video format.
   n. The NTSC default frame rate is 29.97 frames per second.

5) **Multiplexing command**
   o. This is the syntax that DVDStyler uses to pass commands to the “mplex” command of DvdAuthor.

6) **Demultiplexing command**
   p. This is the syntax that DVDStyler uses to pass commands to the “mpgtx” command of DvdAuthor.

7) **Spumaux command**
   q. This is the syntax that DVDStyler uses to pass commands to the “spumux” command of DvdAuthor.

8) **DvdAuthor command**
   r. This is the syntax that DVDStyler uses to pass commands to the “DvdAuthor” command of DvdAuthor.
9) Preview command  
  s. This command is for future use.
10) Create ISO command  
  t. This is the syntax that DVDStyler uses to pass commands to the “mkisofs” command of DvdAuthor.
  u. This syntax is invoked only when the “create iso image” checkbox of the burn menu is checked (follow File -> Burn DVD... to access the burn menu).
11) Burn command  
  v. This is the syntax that DVDStyler uses to pass commands to the “mkisofs” command of DvdAuthor.
  w. This syntax is invoked only when the “create iso image” checkbox of the burn menu is unchecked (follow File -> Burn DVD... to access the burn menu).
12) CdrecordProDVD key  
  x. This is the license key for CdRecordProDvd. DVDStyler uses this program to burn DVDs.
  y. Burning is currently supported only on the Linux distribution of DVDStyler.

Help -> About

This selection displays the program credits, license, and provides a link to the project home page.

Menu Properties

Access menu properties by:

1. Right-click on an open area of the menu editing panel to display the menu properties dialogue. Alternately, you can double-click on an open area of the menu editing panel or double-click on a menu on the timeline.
2. Menu properties assign how the menu will look and play in reference to other menus and movie clips on the finished DVD.

3. Format – The format field describes the size of the menu frame (NTSC or PAL).

4. Background
   a. Image – The image field contains the path and filename of the image file used for the background of the menu. This field automatically populated when you select a background image. To remove the background image, delete the entry in this field.
   b. Color – This is the color of the background image. Click the "…" button to select a color. Note – This selection is disregarded when using a background image.

5. Subtitle (buttons)
   a. Start time – This is the delay applied to the display of all buttons on the menu, after the menu starts to display.
   b. Stop time – This is the delay applied to the remove all buttons on the menu when the menu starts to displayed.
   c. Both Start and End times are in “Hour:Minute:Second.Hundredths” format (hh:mm:ss.hun).
   d. Example:
      i. Assume Start time is "00:00:05.00".
      ii. Assume End time is "00:00:20.00"
      iii. The sequence will be:
           1. Display menu background, then
           2. Wait 5 seconds, then
           3. Display buttons, then
           4. Wait 15 seconds
           5. Remove buttons
   e. Note - These selections are normally used when the background of the menu is a movie clip, not a still image. When using a still image (which is actually a one frame movie clip), the still image usually does not play long enough to get-to the beginning of the “Start time”, resulting in the buttons never being displayed. Leave them both at the default settings (00:00:00.00 and blank) when using a still image.

6. Video object
   a. Pause – This selection creates a pause before executing a “Post command”. It is a convenient way to use a menu to display information prior to displaying another menu. For example: Play the credits (menu 1) for “N” seconds, and then jump-to the navigation menu (menu 2).

7. Menu
   a. Overview – Each menu may be defined as a specific type of menu (Title, Subtitle, Angle, etc.). By default, DVDStyler and DVDAuthor will automatically assign the type to each menu during the rendering process (you do not have to select these). However, you may care to assign these types yourself, as some menu types have DVD player remote control buttons dedicated to servicing their specific functions and others will have application to other DVD features.

<table>
<thead>
<tr>
<th>Menu type assignments (DVDStyler checkbox selection)</th>
<th>Applies to</th>
<th>Remote control buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>VmMenu(s)</td>
<td>Top Menu</td>
</tr>
<tr>
<td>Subtitle</td>
<td>Not supported yet</td>
<td>Subtitle</td>
</tr>
<tr>
<td>Angle</td>
<td>Not supported yet</td>
<td>Angle</td>
</tr>
<tr>
<td>Root</td>
<td>Menu(s)</td>
<td>Menu</td>
</tr>
<tr>
<td>Audio</td>
<td>Not supported yet</td>
<td>Audio</td>
</tr>
<tr>
<td>PPT</td>
<td>Not supported yet</td>
<td>None</td>
</tr>
</tbody>
</table>
b. Menu assignment rules:
   i. The remote controls “Top Menu” button always returns to VmMenu (by default and when defined as “Title”).
   ii. Only VmMenus’s can be assigned as “Title”.
   iii. The remote controls “Menu” button will select the root menu of a titleset.
   iv. Each titleset can have one “Root” menu.
   v. Only one menu per titleset may be selected as “root”.
   vi. Any menu in a titleset can be assigned as the “root”.
   vii. Pressing menu (root) button always goes to the “Root” menu of the titleset you are on at the time.
   viii. If no menu is defined as “Root”, the first menu in the titleset will be displayed when the “Menu” button is pressed.
   ix. The remote control buttons (Top Menu, Menu, Audio, Subtitle, and Angle) will be linked to menu displays only when viewing the menu system. Pressing the buttons while the player is playing a movie will invoke the players default functions.
   x. Pressing menu (root) only has an action while a movie is playing
   xi. Only one subtitle menu may be assigned per titleset
   xii. Pressing Top Menu button while on the VmMenu sometime starts a movie (similar to pressing the “Enter” button).

c. Assign each menu type as desired. Note – These assignments are not validated prior to processing.

d. Pre commands – Any command you wish to execute prior to displaying the menu.

e. Post commands – Any command you with to execute after displaying the menu.

f. Both “Pre” and “Post” command fields can contain multiple commands by separating each command with a semi-colon.

g. Note – These commands are part of the DVD scripting system. Scripting is beyond the scope of this revision of the DVDSstyler manual.

8. Audio / Video button – Refer to the instructions under Title Properties / Audio/Video (below). The instructions for both menu and title properties are virtually identical (except for some selections that appear or disappear, depending on context).

Men Creation Tools

DVDSstyler provides several resources (tools) to create dynamic menus. The components are pre-built and highly configurable. The parts simply require placement and minor adjustments to produce functional, attractive results. The tool set includes several buttons and drawn objects, including frames, rectangles, images, and text.

Frames, Images, Rectangles, and Text

1. Frames
   a. A frame is generally used to apply an outline around another object. The body of the frame can be filled or not filled (transparent), allowing the background of the menu area to show through.
   b. Create a frame by right-clicking on the menu editing panel to access the speed menu. Then select Add -> Frame.
   c. Access the frames properties panel by double-clicking on the frame or right-clicking to access the speed menu.
d. **Look**

i. Rx and Ry – These values represent the rounding radiuses at the corners of the frame.

ii. Set both Rx and Ry to zero if you wish to have square corners on your frame.

iii. Refer to the figures below for various examples of applying rounding radiuses.
iv. Mount width – This value corresponds to the thickness of the frame outline.

v. The mount width range is 0 – 999. However, the practical limit is relative to the size of the frame.

vi. The Mount width increases in size from its centerline as its value is increased. The width of the mount is approximately the size entered in the mount width field (it is actually slightly larger, including the click-area, about 8 pixels per side).

vii. Mount color – This is the color of the mount (frame outline). Click the color pallet button to select a color. Click the fill button to revert the color to transparent.

viii. Inner color - This is the color of the fill area inside of the mount. Click the color pallet button to select a color. Click the fill button to revert the color to transparent.
e. Location
   i. The location coordinates (X and Y) determine where the object appears on the display.
   ii. The frame is positioned by referencing the upper-left corner of the click-area box, not
       the actual frame. The click-area box on small frames is eight pixels from each edge.
       As the frame size increases, the click-area box distance from the frame is positioned
       further away, increasing by eight pixel increments.
   iii. The horizontal range (X) is 0 – 720 pixels. O (zero) is the left-most position, 720 is the
        right-most position. Be careful not to enter a value that positions the frame off the right
        edge of the display as you may not be able to re-access the object
   iv. The vertical range (Y) is 0 – 480 or 576 pixels (NTSC or PAL). O (zero) is the top-most
       position, 480 / 576 is the bottom-most position. Be careful not to enter a value that
       positions the frame off the bottom edge of the display as you may not be able to re-
       access the object

f. Size
   i. The size of the frame is determined by the width and height values.
   ii. Custom - Resizing the frame will automatically be selected the “Custom” radio button.
   iii. Default width and height – Click this radio button to restore the frame to its original size
       (width = 50 pixels / height = 50 pixels)
   iv. Custom – Click this radio button if you wish to change the default width and height
       sizes. This button is automatically clicked when you change the size of the frame with
       the sizing handles.
   v. Width - The width range is 8 – 720 pixels.
   vi. Height - The height range is 8 – 480 or 576 pixels (NTSC or PAL).

2. Images
   a. Images are usually any photographed, filmed, or generally captured picture. DVD menus
      usually incorporate one or more captured images from the title being offered in the
      titleset.
   b. Place an frame on the menu by right-clicking on the menu editing panel to access the
      speed menu. Then select Add -> Image.
   c. Access the image properties panel by double-clicking on the image or right-clicking to
      access the speed menu.
   d. Image – Click the file selection button to the right of the image field to modify the selected
      image.
   e. Supported file formats are JPEG, BMP, PNG, and various others.
f. Opacity – Enter the desired opacity. This is a measure of the amount of background content you will allow to show through to the foreground. The opacity range is 1 – 128. A value of 0 or 129 will make the image transparent.

![Opacity images]

- Opacity = 0
- Opacity = 1
- Opacity = 16
- Opacity = 32
- Opacity = 64
- Opacity = 96
- Opacity = 112
- Opacity = 128
- Opacity = 129

g. Location – The location coordinates (X and Y) determine where the object appears on the display. The location rules for images are similar to the those from the frame, except the click-sensitive area box is on the edge of the image instead of 8 pixels away. However, the default image size is 168 X 128 rather than 160 X 120.

h. Size
i. Default width and height – Click this radio button to restore the image to its original size.
ii. Custom – Click this radio button if you wish to change the default width and height sizes. This button is automatically clicked when you change the size of the frame with the sizing handles.
iii. Width - The range of the image width is 4 – 720 pixels.
iv. Height - The range of the image height is 4 – 480 or 576 (NTSC or PAL)
v. Be careful not to enter 0 (zero) in either of these fields. Entering a 0 will make the image disappear. If you do enter a 0, manually edit the project XML file to re-gain access to the image.

3. Rectangle
a. A rectangle is generally used for various applications (buttons, backgrounds, filler, or whatever you care to apply it to). The body of the frame can be filled or not filled (transparent), allowing the background of the menu area to show through, creating a hole in the thing it is overtop-of.

b. Create a rectangle by right-clicking on the menu editing panel to access the speed menu. Then select Add -> Rectangle.

c. Access the rectangle properties panel by double-clicking on the rectangle or right-clicking to access the speed menu.
d. The majority of the rectangle parameters follow the same instructions as the frame and image selections. Refer to those sections for guidelines, except for the following:
i. The opacity setting has no effect, other than to make the rectangle completely transparent when set to zero.
ii. Color applies to the entire rectangle fill area, not just the outline.

4. Text
a. Text may be used as stand-alone labels, button labels or whatever information you care to include on the menu.
b. Create a text string by right-clicking on the menu editing panel to access the speed menu. Then select Add -> Text.
c. Access the text properties panel by double-clicking on the text or right-clicking to access the speed menu.

d. Look
i. Text
   1. Enter the desired text in this field
   2. The maximum practical string length is about 150 characters (font size 8)
   3. Most alpha-numeric character are valid
ii. **Font**
   1. Click the “Font” button to access the font selection dialog.
   2. Font, font style, and size parameters are supported
   3. Effects, color, and script parameters are not supported

iii. **Fill** - This is the color of the body of the text

iv. **Stroke** - This is the color of the outline of the text

e. **Location**
   i. Location - X and Y horizontal and vertical coordinates of the text click sensitive outline
   ii. This is the location of the text string
   iii. The horizontal range is 0 – 720. O (zero) is the left-most position, 720 is the right-most position.
   iv. The vertical range is 0 – 480 or 576 (NTSC or PAL). O (zero) is the top-most position, 480 / 576 is the bottom-most position.
   v. Be careful not to enter a value that positions the text off the right or bottom edge of the display as you may not be able to re-access the object

f. **Size**
   i. The character size may be modified by changing the text font size (see font instructions above).
   ii. Modifying the focal outline (the red rectangle around the text string) will change the click-sensitive area, but the text size will be unaffected.
   iii. Default height and width – Click this radio button to restore the click-sensitive area to match the size of the font.
   iv. Custom height and width
      1. This is the size of the click-sensitive area around the text string.
      2. The horizontal range is 0 – 720. O (zero) is the left-most position, 720 is the right-most position.
      3. The vertical range is 0 – 480 or 576 (NTSC or PAL). O (zero) is the top-most position, 480 / 576 is the bottom-most position.
      4. Be careful not to enter a value that positions the text off the right or bottom edge of the display as you may not be able to re-access the object

**Buttons**

Most of the buttons offered in DvdStyler perform similar functions. Generally, the navigation settings are common to all buttons, while the look can vary considerably.

**Button Navigation**

Access button properties by:

1. Right click on any menu button (from the menu editing panel).
2. Select “Properties” from the speed menu.

   Note – Options for each drop-down list in the Action section will appear as title sets, titles, chapters, and buttons are added to the timeline and menus.
3. **Action** - This defines what will happen when the “Enter” button of the remote control is pressed.
   a. Jump to
      i. These fields allow you to select a titleset, title, and, chapter to move to. Click the down-arrow control of each field to select a destination to advance-to
      ii. The available selections under each field (titleset, title, and chapters) will change depending on what has been created on the timeline.
   b. Custom
      i. This field allows you to define whatever action you want.
      ii. If the existing “jump to” menus do not offer the desired combination, use the custom field.
      iii. This field can be used similar to the “Pre” commands of various other panels.
      iv. String commands together by separating each with a semicolon.
   c. **Focus**
      i. Left – This defines the action of the remote control “Left” button. Select a menu selection to advance-to when the “Left” remote control button is pressed.
      ii. Right - This defines the action of the remote control “Right” button. Select a menu selection to advance-to when the “Right” remote control button is pressed.
      iii. Up - This defines the action of the remote control “Up” button. Select a menu selection to advance-to when the “Up” remote control button is pressed.
      iv. Down - This defines the action of the remote control “Down” button. Select a menu selection to advance-to when the “Down” remote control button is pressed.
   v. **Auto**
      1. This selection will move the focus to a button that is immediately above, below, left or right of the current location.
      2. If no button exits in one of those directions, pressing the button will have no effect.
      3. Auto does not “wrap around” to buttons on the opposite side of the screen.
         However, you can create that effect by manually selecting a button on the opposite end of the screen.
Unique button looks

5. **Text button** - The Text button provides a simple text string as the button.

   ![Text-Based buttons](image)

   ![My Button](image)

   ![My Puppy](image)

   ![My Puppy](image)

   ![Look](image)

   ![Click here to restore transparent background](image)

   a. **Label** – Edit this field to modify the button text.
   
b. **Font**
      
i. Click the “Font” button to access the font selection dialog.
      
ii. Font, font style, and size parameters are supported
      
iii. Effects, color, and script parameters are not supported
      
iv. Note – The size of the text is adjusted by the font size, not the button area
   
c. **Text color**
      
   vi. Normal – This is the color of the text when the focus is not on the button.
      
vii. Highlighted – This is the color of the text when the focus is on the button.
      
viii. Selected - This is the color text will momentarily change to when the button is selected.
   
d. **Background color**
      
   ix. Normal – This is the color of the text background when the focus is not on the button.
      
x. Highlighted – This is the color of the text background when the focus is on the button.
      
x. Selected - This is the color text background will momentarily change to when the button is selected.

d. **File name** - text.xml

   Note – If you select a background color and later decide to change it back to transparent, click the color box next to the color selection button.

   Note – To have the button displayed on top of the image, insert the image first, and then insert the button (objects are displayed in “creation” order). If you do it in reverse, the image will be displayed overtop of the button.
6. Image-based rectangle button - Description – The image-based rectangle button provides a way to insert an image into a frame. Both the image and frame can be resized and adjusted as needed.

**Image-Based Rectangle buttons**

![Image-Based Rectangle buttons](image)

- **Rx = 1**
- **Ry = 1**
- **Border width = 0**
- **Rx = 1**
- **Ry = 1**
- **Border width = 1**
- **Rx = 20**
- **Ry = 20**
- **Border width = 15**

**Look**

<table>
<thead>
<tr>
<th>Image:</th>
<th>(\text{\textbackslash h\textbackslash v\textbackslash p\textbackslash i\textbackslash c\textbackslash t\textbackslash e\textbackslash s\textbackslash r\textbackslash e\textbackslash r\textbackslash f\textbackslash a\textbackslash m\textbackslash s\textbackslash e\textbackslash l\textbackslash y\textbackslash /f\textbackslash a\textbackslash m\textbackslash e\textbackslash l\textbackslash y\textbackslash /d\textbackslash o\textbackslash g\textbackslash _\textbackslash l\textbackslash e\textbackslash _\textbackslash l0\textbackslash .\textbackslash b\textbackslash m\textbackslash p\textbackslash n)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image opacity:</td>
<td>1</td>
</tr>
<tr>
<td>Rx:</td>
<td>20</td>
</tr>
<tr>
<td>Ry:</td>
<td>20</td>
</tr>
<tr>
<td>Border width:</td>
<td>15</td>
</tr>
</tbody>
</table>

- **a.** Image – Click the file selection button to the right of the image field to modify the selected image.
- **b.** Image opacity – Enter the desired opacity. The opacity range is 1 – 128. A value of 0 or 129 will make the image transparent. Refer to the “Images” section above for examples of “Opacity” settings.
- **c.** Supported file formats are JPEG, BMP, PNG, and various others.
- **d.** Rx and Ry – These values represent the rounding radiuses at the corners of the rectangle.
- **e.** Set both Rx and Ry to zero if you wish to have square corners on your frame. Refer to the “Frames” section above for example of “Rx” and “Ry” settings.
- **f.** Border width - This value corresponds to the thickness of the border outline.
- **g.** The border width range is 0 – 999. However, the practical limit is relative to the size of the image.
- **h.** The border width increases in size from its centerline as its value is increased. The width of the mount is approximately the size entered in the border width field (it is actually slightly larger, including the click-area, about 8 pixels per side). Refer to the ‘Frame’ section above for examples of the border width setting (border width is similar to mount width).
i. Border color
   i. Normal – This is the color of the border when the focus is not on the button.
   ii. Highlighted – This is the color of the border when the focus is on the button.
   iii. Selected - This is the color the border will momentarily change to when the button is selected.

j. Inner color
   i. Normal – This is the color of the inner section of the border (fill) when the focus is not on the button.
   ii. Highlighted – This is the color of the inner section of the border (fill) when the focus is on the button.
   iii. Selected - This is the color of the inner section of the border (fill) will momentarily change to when the button is selected.

k. Notes - Add labels by adding text strings separately, as needed

l. File name - frame.xml

m. Note – Pressing “Default” will restore the button to the frame default size (50 pixels X 50 pixels)

7. Ellipse button – The ellipse button provides you with a way to produce a non-rectangular button. It can be adjusted to be elliptical or perfectly round.

![My Oval Button](image)

<table>
<thead>
<tr>
<th>Look</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mount width: 5</td>
</tr>
<tr>
<td>Mount colour:</td>
</tr>
<tr>
<td>Inner colour:</td>
</tr>
</tbody>
</table>

a. Mount width - This value corresponds to the thickness of the border outline.
b. The mount width range is 0 – 999. However, the practical limit is relative to the size of the image.
c. The mount width increases in size from its centerline as its value is increased. The width of the mount is approximately the size entered in the mount width field (it is actually slightly larger, including the click-area, about 8 pixels per side). Refer to the ‘Frame’ section above for examples of the mount width setting.
d. Mount color
   i. Normal – This is the color of the mount when the focus is not on the button.
   ii. Highlighted – This is the color of the mount when the focus is on the button.
   iii. Selected - This is the color the mount will momentarily change to when the button is selected.

e. Inner color
   i. Normal – This is the color of the inner section of the mount (fill) when the focus is not on the button.
   ii. Highlighted – This is the color of the inner section of the mount (fill) when the focus is on the button.
   iii. Selected - This is the color of the inner section of the mount (fill) will momentarily change to when the button is selected.

f. To make the ellipse round, set the width and height to equal values.
g. File name - ellipse.xml

8. Next arrow button – This button typically point to the next item. It colors can be modified, but resizing maintains its shape, as it is a complex object.

![Next Arrow Button Examples]

a. Color of the mount
   i. Normal – This is the color of the mount when the focus is not on the button.
   ii. Highlighted – This is the color of the mount when the focus is on the button.
   iii. Selected - This is the color the mount will momentarily change to when the button is selected.

b. Color of the arrow
   i. Normal – This is the color of the arrow (fill) when the focus is not on the button.
   ii. Highlighted – This is the color of the arrow (fill) when the focus is on the button.
   iii. Selected - This is the color of the arrow (fill) will momentarily change to when the button is selected.

c. File name - arrow-next.xml
9. Tri-color arrow buttons – This button will typically point to another thing (menu, settings, start film, etc). The tri-color arrow can be adjusted to have various looks. Two of the colors fade into each other, while the third acts as a bright or dark point.

- **Color 1** – This is the color of the focus point inside of the fill area of the buttons circle (upper-left side). Click the color pallet button to select a color. Click the fill button to revert the color to transparent.
- **Color 2** – This is the color of the upper-left side of the circle fill area. The fill area will fade from this color to the color selected in “Color 3” (lower-right side of circle fill area).
- **Color 3** – This is the color of the lower-right side of the circle fill area. The fill area will fade from this color to the color selected in “Color 2” (upper-left side of circle fill area).
- **Color of the mount** - This is the color of the mount (outline of the circle). Click the color pallet button to select a color. Click the fill button to revert the color to transparent.
- **Color of the arrow** - This is the color of the fill area inside of the arrow. Click the color pallet button to select a color. Click the fill button to revert the color to transparent.

**File names**
- Left - arrow2-left.xml
- Right - arrow2-right.xml
- Up - arrow2-up.xml
- Down - arrow2-down.xml

10. Two color arrow buttons – The two color button is similar to the tri-color button, but allows for fewer adjustments. It also has a slightly different look around the mount edge.
a. Color of the circle – This is the color of the fill area of the circle. It also appears outside of the mount color. Click the color pallet button to select a color. Click the fill button to revert the color to transparent.

b. Color of the mount – This is the color of the mount (outline of the circle). Click the color pallet button to select a color. Click the fill button to revert the color to transparent.

c. Color of the arrow - This is the color of the fill area inside of the arrow. Click the color pallet button to select a color. Click the fill button to revert the color to transparent.

d. File name
   i. Left - arrow-left.xml
   ii. Up - arrow-up.xml
   iii. Right - arrow-right.xml
   iv. Down - arrow-down.xml

11. OK (check) button / Cancel button – These button indicate accepting or rejecting a given selection.
Look

- Fill – This is the color of the fill area of the check-mark or X. Click the color pallet button to select a color. Click the fill button to revert the color to transparent.
- Stroke - This is the color of the outline of the check-mark or X. Click the color pallet button to select a color. Click the fill button to revert the color to transparent.
- File names - ok.xml / cancel.xml

Location and Size

d. Location
   i. The location coordinates (X and Y) determine where the button appears on the display.
   ii. The button is positioned by referencing the upper-left corner of the click-area box, not the actual button. The click-area box on small buttons is 8 pixels from each edge. The button size increases, the click-area box distance from the button is positioned further away, increasing by eight pixel increments.
   iii. The horizontal range (X) is 0 – 720 pixels. O (zero) is the left-most position, 720 is the right-most position. Be careful not to enter a value that positions the button off the right edge of the display as you may not be able to re-access the object.
   iv. The vertical range (Y) is 0 – 480 or 576 pixels (NTSC or PAL). O (zero) is the top-most position, 480 / 576 is the bottom-most position. Be careful not to enter a value that positions the button off the bottom edge of the display as you may not be able to re-access the object.

e. Size
   i. The size of the button is determined by the width and height values.
   ii. Custom - Resizing the button will automatically be selected the “Custom” radio button.
   iii. Default width and height – Click this radio button to restore the button to its original size (width = 50 pixels / height = 50 pixels).
   iv. Custom – Click this radio button if you wish to change the default width and height sizes. This button is automatically clicked when you change the size of the frame with the sizing handles.
   v. Width - The width range is 8 – 720 pixels.
   vi. Height - The height range is 8 – 480 or 576 pixels (NTSC or PAL).

Drawing editor notes:

1. Horizontal and vertical handles don’t exist on text objects or frame objects. All handles are corner handles. Always grab the object by the corner or it will be resized to the spot that you contacted it.
2. Things tend to shift when you put the focus on them if you mouse-click on the upstroke.
3. On an English keyboard, the valid characters are: `, 1, 2, 3, 4, 5, 6, 7, 8, 9, 0, =, q, w, e, r, t, y, u, i, o, p, [, ], a, s, d, f, g, h, j, k, l, ;, ’, z, x, c, v, b, n, m, /, @, $, %, ^, &, *, ( ), _,-, +, Q, W, E, R, T, Y, U, I, O, P, {, }, |, A, S, D, F, G, H, J, K, L, :, ”, Z, X, C, V, B, N, M, <, >, ?
4. Objects placed on the menu drawing area are displayed in creation order. If two or more items are placed over-top of each other, the last created will be on top.

2/22/2006
DVDSstyler Operators Manual: Program V. 1.5 25
5. There is no “bring to top” feature. If you wish to move an item to the top, simply copy the item and paste it in the same location.
6. Switch from custom to default and the click area changes to match font size, but the text will be relocated to coordinates 0,0
7. Default fill color is white. If background color is white, the text will disappear, so change the fill color before losing the focus.

**Title Properties**

Access title properties by:

1. Right click on any title on the timeline.
2. Select “Properties” from the speed menu.

Title properties assign how the clip will play in reference to other titles on the DVD (they are not the properties of the individual title). They define actions that will happen before, during, and after a title is played. For example, when a user presses a “Play Movie” button, you might want it to:

1. Go straight to playing the title, or
2. Play a copyright clip before playing the movie, or
3. Play an introduction to the title, or
4. Play anything you care to prior to or after playing the movie.

Each selection on the menu may invoke an action at various times of the movie clip playing, which are:

1. Chapters – These are chapter points for the title. Each value represents the elapsed time into the movie where the movie clip will begin to play when jumped-to.
   a. Although it is not shown in the properties panel, chapter one starts at Time = 0 = the beginning of the movie; Chapter two would be at Time = 15:00 = 15 minutes into the movie clip, etc.
   b. Each clip that is assigned to the movie timeline receives a default set of chapter points that are shown in this field.
   c. See “Setting-up Chapter Points” for additional details on creating and assigning chapter points.
2. Pause – This assigns the delay between playing this clip and the next clip to be played. This is normally set to zero.
3. Pre Commands – This defines actions that may be executed prior to playing the movie clip.
4. Post Commands - This defines actions that may be executed after playing the movie clip. Typically you would want the playback to proceed to the next clip or automatically return to the main menu.

**Audio / Video Properties**

Access the audio and video encoding properties by clicking the Audio/Video button. The next panel of settings allows you to set various parameters of both the audio and video streams. Setting the audio and video (A/V) properties of both menus and titles follows basically the same process. The panels allow you to set various properties that are invoked during the rendering process.

![Audio/Video Properties Panel]

DVDStyler provides a field for each DVDAuthor command line switch that is available to the user. However, DVDAuthor does not usually treat these properties as instructions. DVDAuthor generally does some analysis on the video and audio stream prior to operating on it, then uses or discards the settings, depending on the analysis.

Most parameters are inferred automatically from the source VOBs except for PCM parameters. However, language must be manually specified. Note that it is possible to just list the language attribute and let dvdauthor fill in the rest.

1. Audio - Format
   a. Definition - Format represents the criteria used to encode the audio signal when converting it from an analog signal to a digital signal. Each format has very specific methods of sampling, compressing, and digitizing the audio signal.
   b. Auto
      i. DVDAuthor will automatically detect the audio format
      ii. DVDAuthor virtually always uses the detected results
   c. mp2
      iii. Also known as MPEG-1 Layer 2
      iv. MythTV often encodes the audio stream in this format
v. Use this selection if you want to tell DVDAuthor this audio format
vi. Selecting mp2 will not transform the audio format. It simply provides information to
DVDAuthor for processing purposes.

d. ac3
vii. Also known as Dolby Digital audio
viii. Most commercial DVD productions use this format
ix. Use this selection if you want to tell DVDAuthor this audio format
x. Selecting ac3 will not transform the audio format. It simply provides information to
DVDAuthor for processing purposes

e. dts
xi. Also know as Digital Theatre Systems-Digital Surround
xii. DTS is a multi-channel digital audio format
xiii. Use this selection if you want to tell DVDAuthor this audio format
xiv. Selecting dts will not transform the audio format. It simply provides information to
DVDAuthor.

f. pcm
xv. Also know as Pulse Code Modulation
xvi. Also known as LPCM – Linear Pulse Code Modulation
xvii. Linear PCM is uncompressed (lossless) digital audio
xviii. Linear PCM is the same format used on CDs and most studio masters
xix. Use this selection if you want to tell DVDAuthor this audio format
xx. Selecting pcm will not transform the audio format. It simply provides information to
DVDAuthor.

2. Audio - Channels
   a. Definition – Channels defines the number of channels included with the audio title
      (stereo, surround, center, etc)
   b. Enter 1 through 7
   c. Valid entries are 1, 2, 3, 4, 5, 6, 7, 8
   d. 0, 9, and text are not valid entries
   e. From experience – DVDAuthor uses the auto-detected values.

3. Audio - Quantity
   a. Definition - Quantity (measured in bits per sample – bps) refers to the number of bits
      used when sampling the audio signal. Generally, the more bits per sample, the higher
      the audio quality. However, the more bits per sample, the more space is required.
   b. Audio CD is limited to 44.1 kHz at 16 bits per sample
   c. DVD quantity selections are 16 bps, 20 bps, and 24 bps
   d. DVD quantity selection also offers “drc”
      i. Dolby Digital Dynamic Range Compression (DRC)
      ii. Dynamic Range Compression reduces the difference between very loud and very quiet
      sounds so the viewer does not have to turn the sound up and down throughout the
      course of the movie. Parents use this feature to avoid waking up the kids.
   e. From experience – DVDAuthor uses your selected values (reflected in the “inf” file),
      however, the DVD player may, or may not observe it.

4. Audio - Dolby
   a. Definition – A method of audio noise reduction and effects encoding (Dolby Labs, tradedmarked).
   b. Auto – DVDAuthor will automatically detect this setting.
   c. Surround – Use this selection if you want to tell DVDAuthor this audio format
   d. From experience – DVDAuthor uses the auto-detected values

5. Audio - Samplerate
   a. Definition – Samplerate is the frequency at which the analog audio signal has been
      sampled when being converted to digital. The higher the frequency (or more often it is
      sampled), the better the quality. However, the higher the rate, the more space is
      required. Samplerate is measured in kHz, also known as kilo-hertz, also known as
      thousand cycles per second. A higher frequency generally results in better quality.
   b. Auto – DVDAuthor will automatically detect this setting.
c. 48 kHz – Use this selection if you want to tell DVDAuthor the Samplerate of 48 kHz.
d. 96 kHz – Use this selection if you want to tell DVDAuthor the Samplerate of 96 kHz.
e. Selecting 48 kHz or 96 kHz will not transform the audio sample rate. It simply provides information to DVDAuthor.

6. Audio - Language
a. Definition – The language of the audio track.
b. Enter the desired language code (see table below).
c. Entering a language code does not transform the audio to a different language. It simply provides information to DVDAuthor for processing.
d. From experience – DVDAuthor uses your entered values (reflected in the “inf” file),

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Afar</td>
<td>aa</td>
<td>Interlingue</td>
<td>ie</td>
<td>Sanskrit</td>
<td>sa</td>
</tr>
<tr>
<td>Abkhazian</td>
<td>ab</td>
<td>Inupiak</td>
<td>ik</td>
<td>Scots Gaelic</td>
<td>gd</td>
</tr>
<tr>
<td>Afrikaans</td>
<td>af</td>
<td>Irish</td>
<td>ga</td>
<td>Serbian</td>
<td>sr</td>
</tr>
<tr>
<td>Albanian</td>
<td>sq</td>
<td>Islenska(Icelandic)</td>
<td>is</td>
<td>Serbo-Croatian</td>
<td>sh</td>
</tr>
<tr>
<td>Amharic (Amharic)</td>
<td>am</td>
<td>Italiano (Italian)</td>
<td>it</td>
<td>Sesotho</td>
<td>st</td>
</tr>
<tr>
<td>Arabic</td>
<td>ar</td>
<td>Inuktitut</td>
<td>ju</td>
<td>Setswana</td>
<td>tn</td>
</tr>
<tr>
<td>Armenian</td>
<td>ia</td>
<td>Japanese</td>
<td>ja</td>
<td>Shona</td>
<td>sn</td>
</tr>
<tr>
<td>Assamese</td>
<td>as</td>
<td>Javanese</td>
<td>jw</td>
<td>Sinhalese</td>
<td>si</td>
</tr>
<tr>
<td>Aymara</td>
<td>ay</td>
<td>Kannada</td>
<td>kn</td>
<td>Sindhi</td>
<td>sd</td>
</tr>
<tr>
<td>Azerbaijani</td>
<td>az</td>
<td>Kashmiiri</td>
<td>ks</td>
<td>Siswati</td>
<td>ss</td>
</tr>
<tr>
<td>Bashkir</td>
<td>ba</td>
<td>Kazakh</td>
<td>kk</td>
<td>Slovak</td>
<td>sk</td>
</tr>
<tr>
<td>Basque</td>
<td>eu</td>
<td>Korean</td>
<td>ko</td>
<td>Slovenian</td>
<td>sl</td>
</tr>
<tr>
<td>Bhutani</td>
<td>dz</td>
<td>Kurdish</td>
<td>ku</td>
<td>Somali</td>
<td>so</td>
</tr>
<tr>
<td>Bihari</td>
<td>bh</td>
<td>Kinyarwanda</td>
<td>rw</td>
<td>Sundanese</td>
<td>su</td>
</tr>
<tr>
<td>Bislama</td>
<td>bi</td>
<td>Kirghiz</td>
<td>ky</td>
<td>Svenska</td>
<td>sv</td>
</tr>
<tr>
<td>Bengali;Bangla</td>
<td>bn</td>
<td>Kirundi</td>
<td>ln</td>
<td>Swahili</td>
<td>sw</td>
</tr>
<tr>
<td>Breton</td>
<td>br</td>
<td>Latin</td>
<td>la</td>
<td>Tagalog</td>
<td>tl</td>
</tr>
<tr>
<td>Bulgarian</td>
<td>bg</td>
<td>Lingala</td>
<td>ln</td>
<td>Tajik</td>
<td>tg</td>
</tr>
<tr>
<td>Burmese (Myanmar)</td>
<td>my</td>
<td>Laothian</td>
<td>lo</td>
<td>Tamil</td>
<td>ta</td>
</tr>
<tr>
<td>Byelorussian</td>
<td>be</td>
<td>Lithuanian</td>
<td>lt</td>
<td>Tatar</td>
<td>tt</td>
</tr>
<tr>
<td>Cambodian</td>
<td>km</td>
<td>Latvian, Lettish</td>
<td>lv</td>
<td>Telugu</td>
<td>te</td>
</tr>
<tr>
<td>Català (Catalan)</td>
<td>ca</td>
<td>Macedonian</td>
<td>mk</td>
<td>Thai</td>
<td>th</td>
</tr>
<tr>
<td>Chinese</td>
<td>zh</td>
<td>Magyar</td>
<td>hu</td>
<td>Tibetan</td>
<td>bo</td>
</tr>
<tr>
<td>Corsican</td>
<td>co</td>
<td>Malagasy</td>
<td>mg</td>
<td>Tigrinya</td>
<td>ti</td>
</tr>
<tr>
<td>Czech (Ceske)</td>
<td>cs</td>
<td>Malay</td>
<td>ms</td>
<td>Tonga</td>
<td>to</td>
</tr>
<tr>
<td>Dansk (Danish)</td>
<td>da</td>
<td>Malayalam</td>
<td>ml</td>
<td>Tsonga</td>
<td>ts</td>
</tr>
<tr>
<td>Deutsch</td>
<td>de</td>
<td>Maltese</td>
<td>mt</td>
<td>Turkish</td>
<td>tr</td>
</tr>
<tr>
<td>English</td>
<td>en</td>
<td>Maori</td>
<td>mi</td>
<td>Turkmen</td>
<td>tk</td>
</tr>
<tr>
<td>Esperanto</td>
<td>eo</td>
<td>Marathi</td>
<td>mr</td>
<td>Twi</td>
<td>tw</td>
</tr>
<tr>
<td>Español</td>
<td>es</td>
<td>Moldavian</td>
<td>mo</td>
<td>Uighur</td>
<td>ug</td>
</tr>
<tr>
<td>Estonian</td>
<td>et</td>
<td>Mongolian</td>
<td>mn</td>
<td>Ukrainian</td>
<td>uk</td>
</tr>
<tr>
<td>Finnish</td>
<td>fi</td>
<td>Nauru</td>
<td>na</td>
<td>Urdu</td>
<td>ur</td>
</tr>
<tr>
<td>Fiji</td>
<td>fj</td>
<td>Nederlands</td>
<td>nl</td>
<td>Uzbek</td>
<td>uz</td>
</tr>
<tr>
<td>Faroese</td>
<td>fo</td>
<td>Nepali</td>
<td>ne</td>
<td>Vietnamese</td>
<td>vi</td>
</tr>
<tr>
<td>Français</td>
<td>fr</td>
<td>Norsk</td>
<td>no</td>
<td>Volapuk</td>
<td>vo</td>
</tr>
<tr>
<td>Frisian</td>
<td>fy</td>
<td>Occitan</td>
<td>oc</td>
<td>Welsh</td>
<td>cy</td>
</tr>
<tr>
<td>Galician</td>
<td>gl</td>
<td>Oriya</td>
<td>or</td>
<td>Wolof</td>
<td>wo</td>
</tr>
<tr>
<td>Georgian</td>
<td>ka</td>
<td>Oromo (Afan)</td>
<td>om</td>
<td>Xhosa</td>
<td>xh</td>
</tr>
<tr>
<td>Greek</td>
<td>el</td>
<td>Pashto, Pushto</td>
<td>ps</td>
<td>Yiddish</td>
<td>ji</td>
</tr>
<tr>
<td>Greenlandic</td>
<td>kl</td>
<td>Persian</td>
<td>fa</td>
<td>Yiddish</td>
<td>yi</td>
</tr>
</tbody>
</table>
7. Video – Format
   a. Note - The “Format” selection is only available on the Title properties panel. Menu format is defined on the menu properties panel.
   b. Definition - Format represents the criteria used to encode the video signal when converting it from an analog signal to a digital signal. Each format has very specific methods of sampling, compressing, and digitizing the video signal.
   c. auto - DVDAuthor will automatically detect this setting.
   d. pal – Use this selection if you want to tell DVDAuthor the video track is in PAL format.
   e. ntsc – Use this selection if you want to tell DVDAuthor the video track is in NTSC format.
   f. From experience – DVDAuthor uses your selected values (reflected in the “inf” file).
8. Video – Resolution
   a. Note - The “Resolution” selection is only available on the Title properties panel. Menu resolution is defined on the menu properties panel when the format is selected.
   b. Definition – Resolution is the number of horizontal and vertical points (pixels) that the video image will fit onto the TV display.
   c. For NTSC, valid entries are 720x480, 704x480, 352x480, and 352x240.
   d. For PAL, valid entries are 720x576, 704x576, 352x576, and 352x288.
   e. DVD author will accept a wider range of inputs and round up to the nearest size.
   f. From experience - DVDAuthor uses your entered values (reflected in the “inf” file),
9. Video - Aspect ratio
   a. Definition - Aspect ratio is the relationship between the horizontal and vertical size of the video display. This is described, at length, in other sections of this manual.
   b. auto - DVDAuthor will automatically detect this setting.
   c. 4:3 - Use this selection if you want to use the 4:3 ratio.
   d. 16:9 - Use this selection if you want to use the 16:9 ratio.
   e. From experience - DVDAuthor uses your selected values. If a title is encoded in 4:3 and you set this value to 16:9, some players will try to render the video image to 16:9.
10. Video - Caption
    a. Definition - Caption enables the Closed (or Open) Caption feature of the title. Closed caption has some minor (but significant) differences from subtitles and is handled as a separate feature.
    b. This field is currently unsupported by DVDStyler.
11. Video - Widescreen
    a. Definition - Widescreen methods are sometimes used when transferring film titles to video. Both methods use mattes to block out sections of video content in order to make the content fit the 4:3 TV screen. DVD provides several combinations of video storage and rendering. Widescreen selections allow the user to account for the method used.
    b. auto - DVDAuthor will automatically detect this setting.
    c. nopanscan - Use this selection to tell DVDAuthor that Pan and Scan has not been used.
    d. noletterbox - Use this selection to tell DVDAuthor that Letterbox has not been used.
    e. From experience - DVDAuthor uses your selected values.

Additional notes about the playback flow control:
1. Additional information about playback flow control is available at the DvdAuthor website (http://www.dvdauthor.com/tech01.htm)
2. VOB - The VOBs represent the multiplexed audio, video, and sub-picture overlay.
3. PGC = Program chain.
4. Each Program Chain is made up of a pre-command, a group of programs, and a post-command.
5. VMGM refers to the top level menu. In a multiple menu system, the top-level is the beginning of the menu tree (usually the first menu you see).

Setting menu background color

The menu background may be filled with a solid color of your choice. You can select between a set of 48 basic colors or create a custom color. See “Setting Menu Background Image” for details on using an image for the background instead of a solid color.

1. Start DVDStyler -> Click “Backgrounds” tab -> Right-click on “Menu Editing Panel” -> Select “Properties” -> Click the navigation button next to the “Colour” selection
2. Click on the “Basic color” of your choice or create a custom color.

Setting menu background image

1. Start DVDStyler -> Click “Backgrounds” tab
   a. Double click on an image on the “Backgrounds” tab, or
   b. Right-click on “Menu Editing Panel” -> Select “Properties” -> Click on the “Background / Image” field. Enter the drive, directory, and file name of your choice.
   c. Alternate method – Start DVDStyler -> Click “Directories” tab
2. Navigate to a directory that has your image(s).
   a. Image thumbnails will be displayed on the top-center display panel.
   b. Double-click on the image of your choice.
   c. The image will be inserted as the menu background.
   d. Note – see “General Notes, Menu Creation Tips, and Known Issues - Item #1” for instruction on getting your images to appear in the “Backgrounds” panel.
3. The image you select should be properly sized for the background. It will be automatically stretched and re-sized to fully fit the menu window. The image will appear warped if it is not properly sized.
   a. PAL – 720 X 576
   b. NTSC – 720 X 480
4. The background image shown below is simply a white background with two red lines. Additional images can be added on top of this image by dragging them from the backgrounds panel (then position and resize).
Configuring "Enter", "Up", "Down", "Left", "Right" button actions

This section describes how to associate the actions of the buttons on the remote control with buttons displayed on the DVD menu. While the menu is displayed during playback, pressing any of the remote control buttons will have a specific action on the menu.

For example, highlighting a menu button and pressing the remote control "Enter" button will normally advance playback to the movie clip associated with the button. Pressing the remote control "Down" button will advance the highlighted menu selection to the next selection on the menu. Pressing the "Up" button will advance the highlighted selection to the previous selection, etc.

Pressing the remote controls’ left, right, up, or down buttons will move the focus on the menu from one item to the next. While defining these actions can become somewhat confusing, they can also be simplified to eliminate the confusion. Try to get at least a mental picture of the navigation before assigning button actions.

Simple remote control button navigation

- Only ‘Up’ and ‘Down’ remote control button actions are defined for each menu selection.
- Pressing any remote control navigation button has a pre-defined action. In this case, only up and down actually do anything.

Example:
- Operator highlights the ‘Movie 2’ menu selection
- Press ‘Down’ and advance to ‘Movie 3’
- Press ‘Up’ and advances to ‘Movie 1’
- Press ‘Left’ and menu does nothing
- Press ‘Right’ and menu does nothing
1. Define button actions by (this assumes the menu has been created with buttons applied):
   a. Right-click on the desired menu buttons speed menu -> Select properties

   ![Diagram of complex remote control button navigation]

   b. Note – Options for each drop-down list will appear as movie clips are added to the timeline. With a single movie clip on the timeline, no navigation options will be listed (other than “None”). With three movies on the timeline, two options will be available (it would be three, but picking yourself would be a nonsensical selection).

c. **Action** – This defines what will happen when the “Enter” button of the remote control is pressed. Click the down-arrow control to select a movie clip to advance-to.

d. **Text** – This is the text that will be displayed for the button. Enter any alpha-numeric text for the button name.

e. **Font** – Click on the font selection button to modify the “Text” font properties.

f. **Left** – This defines the action of the remote control “Left” button. Select a menu selection to advance-to when the “Left” remote control button is pressed.

g. **Right** - This defines the action of the remote control “Right” button. Select a menu selection to advance-to when the “Right” remote control button is pressed.

h. **Up** - This defines the action of the remote control “Up” button. Select a menu selection to advance-to when the “Up” remote control button is pressed.
i. **Down** - This defines the action of the remote control “Down” button. Select a menu selection to advance-to when the “Down” remote control button is pressed.

j. **Text colour (Normal)** – This defines the color of the buttons text while the button is not selected.

k. **Text colour (Highlighted)** – This defines the color the buttons text will change to while the button is selected.

l. **Text colour (Selected)** – This defines the color the text will change to when the button is selected by pressing “Enter” on the remote control. It stays in effect until the buttons “Action” is executed.

m. **BG Colour (Normal)** – This is the background color of the text box while button is not selected.

n. **BG Colour (Highlighted)** – This defines the color the text box background will change-to while button is selected.

o. **BG Colour (Selected)** – This defines the color the text box background will change-to when the button is selected by pressing “Enter” on the remote control. It stays in effect until the buttons “Action” is executed.

p. Note – If you select a background color and later decide to change it back to transparent, click the color box next to the color selection button.

q. Note – Buttons may be applied over-top of images. The have the button displayed on top of the image, insert the image first, and then insert the button (objects are displayed in “creation” order). If you do it in reverse, the image will be displayed overtop of the button.

### Setting-Up Chapter Points

Setting up chapter points in DVDStyler is fairly simple, once you understand the basics of chapter points. However, assigning chapter points to buttons can become somewhat confusing, partially because it is done in two separate processes. The following examples use a single menu with multiple chapter points.

The program automatically provides five default chapter points for each clip that is assigned to the movie timeline. Access the defaults by: Right click on a movie clip on the timeline -> Select properties -> View “VOB Chapters” field. The default chapter points are:

0 15:00 30:00  45:00  1:00:00

The first step is to determine where you want the chapter points to fall. If your movie clip was 60 minutes long (1 hour, 00 minutes), the default chapter points would make sense. The sequence would be (refer to diagrams below):

1. Chapter one start point = 0  (00 hours, 00 minutes, 00 seconds)
2. Chapter two start point =  15:00  (00 hours, 15 minutes, 00 seconds)
3. Chapter three start point = 30:00  (00 hours, 30 minutes, 00 seconds)
4. Chapter four start point = 45:00  (00 hours, 45 minutes, 00 seconds)
5. Chapter five - Unused - 1:00:00  (1 hours, 00 minutes, 00 seconds)
However, most movies are not this convenient. You need to determine sensible chapter points. One simple method is to:

1. Determine the length of your movie clip. For this example, assume it is 40 minutes.
2. For a movie clip with four chapters, divide the movie clip length by four (40 / 4 = 10 minutes per chapter). This will result in four separate and equal chapters that are 10 minutes apart:
   a. Start of chapter one = 0 (00:00:00)
   b. Start of chapter two = 10:00 (00:10:00)
   c. Start of chapter three = 20:00 (00:20:00)
   d. Start of chapter four = 30:00 (00:30:00)
   e. End of movie clip = 40:00 (Not used)
3. Edit the chapter points to look like:
   a. 0, 10:00, 20:00, 30:00
   b. Note – You can have additional entries in the chapter field, but they will only have and effect if they are assigned to buttons.

Most professional DVD productions assert chapter points in various points in the movie clip that coincide with the content of the movie, but those points do not usually land at convenient “N” minute intervals. You can determine the exact second to assert a chapter by previewing the clip in a movie editor, but doing so is beyond the scope of this discussion. If you do determine them, by all means, use them here.

The next step is to create buttons that coincide with the chapter points. In the following example menu there are five buttons created for each movie clip. The first button is simply for “Play Movie”, which starts at the beginning of the clip and uses no chapters. Each of the “Chapter” buttons has a chapter assigned to it by editing the button properties:

1. Assume that the buttons have already been placed on the menu (similar to the “Typical Single Menu…” diagram below).
2. Right click on the button for “Chapter 1” -> select “Properties”
3. Modify the “Action” field to include the chapter point:
   a. Jump title 1 Chapter 1;
4. Repeat steps 2 and 3 for each “chapter” button on the menu, adding the chapter point for each button:
   a. Action field for Chapter 1 button - jump title 1 chapter 1;
   b. Action field for Chapter 2 button - jump title 1 chapter 2;
   c. Action field for Chapter 3 button - jump title 1 chapter 3;
   d. Action field for Chapter 4 button - jump title 1 chapter 4;
   e. Note – The default chapter point at “1:00:00” is unused.
5. Repeat steps 2 – 4 for each movie clip on the menu.

6. Note – After editing the “Action” field and closing the “Properties” menu the field might appear blank when you reopen the “Properties” menu. This happens only in the Windows distribution. The Linux distribution properly displays the entry.

Miscellaneous speed menus and buttons

1. Right mouse click on menu editing panel (in an area where no other objects have been placed)
   a. Grid -> (8 X 8 or 16 X 16 or 32 X 32)
      i. The grid selection allows the operator to set the “snap-to” grid spacing. Any objects applied to the menu editing panel will align to other objects automatically. Try to use the same “snap to” resolution throughout an entire project. Snap-to resolutions are:
      ii. None – Disables “snap-to” function
      iii. 8 X 8 – Applies a fine “snap-to” resolution (moves objects 8 pixels at a time)
      iv. 16 X 16 - Applies a medium “snap-to” resolution (moves objects 16 pixels at a time)
      v. 32 X 32 - Applies a coarse “snap-to” resolution (moves objects 32 pixels at a time)
   b. Add -> Text
      i. Allows the operator to add simple text to the menu.
ii. Text entries are not associated with any menu pick-region areas.
iii. Text properties may be adjusted (font and color) by right-clicking on the object and accessing the object speed menu (properties).

c. Properties
i. Allows the operator to adjust various settings for the menus rendered mpeg properties (video format, background, and subtitle properties).

2. Right mouse click on an image, or text box, or button box
   a. Delete – Deletes the object.
   b. Properties – Allows the operator to adjust properties of the selected object.

3. Right mouse click on movies on timeline
   a. Clip name
   b. Delete – Deletes the clip from the timeline.
   c. Properties – Allows the operator to adjust properties of the selected clip.
      i. Vob Chapters
      ii. Vob pause
      iii. Title Pre commands
      iv. Title Post commands

4. Quick buttons
   a. Quick buttons are duplicate selections (in most cases) of functions found under various top menu selections that are conveniently located for repetitive actions.
Creating multiple menus (single titleset)

Using multiple menus allows the designer to organize a highly flexible navigation system. The following example demonstrates a typical method of arranging the menus.

Menu 1

Creating the menus
1. Click “File” -> “New” to create a new project. Upon creation, the first menu will be automatically placed on the movie timeline.

![Image of menu creation process](image1)

2. Right-click on the “Menu 1” image or anywhere on the movie timeline. From the speed menu, select “Add Menu…”. A second menu will automatically be placed on the movie timeline.

![Image of adding a second menu](image2)

3. Continue to create menus as desired. When completed, click on “Menu 1” to place the focus on the first menu.

4. Click on the “Backgrounds” tab on the left-hand edge of the program window. Double-click on any of the displayed background thumbnails to select a background. The selected background image will be displayed in the “Menu 1” timeline image. Place the focus on each timeline menu image and select backgrounds for each menu.

Note – If the “Backgrounds” panel is not displaying the desired images, click on the “Directories” tab and navigate to the proper directory. A new panel will be displayed with thumbnails of any images found on that directory. Double-click on the desired image to select the background.

![Image of background selection process](image3)
5. Any of the selected menu backgrounds may be changed at any time by placing the focus on the desired menu (on the timeline) and double-clicking on a different background image.

**Selecting movie clips**

Now that the menus have been created, it is time to select movies to play. Try to select all the movie clips you plan to put into the project before creating or configuring any of the menu buttons (demonstrated later in this section). Button configuration speed-menus will include lists of items are present on the movie timeline, but it can not provide selections that are not on the timeline yet.

Select each movie clip you care to include as describe in the “Guide / Select a movie clip” section of this manual. Once all the clips have been selected, the timeline should look similar to:

![Movie Timeline](image-url)

**Apply buttons to the menus**

Now that the menu and movie clip assets have been added to the movie timeline, it is time to create the navigation scheme for the menu-system by adding and configuring buttons to each menu. The menus shown at the beginning of this section have four buttons on each menu. Each button may be fully configured for remote control key-presses, however, for the moment, just configure the **Action** and **Text** parameters of each button.

**Add buttons to the menus**

1. Place the focus on the first menu on the timeline (Menu 1)
2. Click on the “Buttons” tab at the left hand edge of the program window.
3. Left-click-hold-and-drag a button from the Buttons pane onto the menu editing pane (as described in the **Guide** section of this manual). Position the button as desired.
4. Repeat step three for all the buttons you care to include on the menu.
5. Left click on the first added button (on menu editing panel) to put the focus on button1.
6. Access the button parameters by right-clicking on the new button.
7. Modify the buttons Action and Text as desired. Select “jump title n;” for buttons that will point to movies and “jump menu n;” for buttons that will point to other menus.
8. Repeat steps 1 through 7 for each menu.
9. Default chapter points are created for each movie clip that is added to the movie timeline. Follow the instruction in Advanced Features / Setting up Chapter Points to properly adjust the chapter points.

Menu 1 / Button 1

<table>
<thead>
<tr>
<th>Action</th>
<th>jump title 1;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Play First Movie</td>
</tr>
<tr>
<td>Font</td>
<td>...</td>
</tr>
</tbody>
</table>

Menu 2 / Button 1

<table>
<thead>
<tr>
<th>Action</th>
<th>jump title 1 chapter 1;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Chapter 1</td>
</tr>
<tr>
<td>Font</td>
<td>...</td>
</tr>
</tbody>
</table>

Once all the button Action and Text parameters have been configured, complete the configuration of all the remote control buttons by following the instructions described in Configuring “Enter”, “Up”, “Down”, “Left”, “Right” button actions section of this manual.

This example has the following navigation layout:

**Menu 1 / Button 1**
1. Button Text reads “Play First Movie”
2. Button Action points to the beginning of the first movie clip ( jump title 1; ).

**Menu 1 / Button 2**
3. Button Text reads “Movie 1 - Chapters”
4. Button Action points to the second menu ( jump menu 2; ).

**Menu 1 / Button 3**
5. Button Text reads “Play Second Movie”
6. Button Action points to the beginning of the second movie clip ( jump title 2; ).

**Menu 1 / Button 4**
7. Button Text reads “Movie 2 - Chapters”
8. Button Action points to the third menu ( jump menu 3; ).

**Menu 2 / Button 1**
1. Button Text reads “Chapter 1”
2. Button Action points to chapter one of the first movie clip (jump title 1 chapter 1;)

Menu 2 / Button 2
3. Button Text reads “Chapter 2”
4. Button Action points to chapter two of the first movie clip (jump title 1 chapter 2;)

Menu 2 / Button 3
5. Button Text reads “Chapter 3”
6. Button Action points to chapter three of the first movie clip (jump title 1 chapter 3;)

Menu 2 / Button 4
7. Button Text reads “Chapter 4”
8. Button Action points to chapter four of the first movie clip (jump title 1 chapter 4;)

Menu 3 / Button 1
1. Button Text reads “Chapter 1”
2. Button Action points to chapter one of the second movie clip (jump title 2 chapter 1;)

Menu 3 / Button 2
3. Button Text reads “Chapter 2”
4. Button Action points to chapter two of the second movie clip (jump title 2 chapter 2;)

Menu 3 / Button 3
5. Button Text reads “Chapter 3”
6. Button Action points to chapter three of the second movie clip (jump title 2 chapter 3;)

Menu 3 / Button 4
7. Button Text reads “Chapter 4”
8. Button Action points to chapter four of the second movie clip (jump title 2 chapter 4;)

Diagram of menu interactions...
Using a video clip on the menu background

Any menu can use either a still picture or motion video for the background of the menu. Actually, the still picture is converted to a single frame video clip when the project is rendered (burned). Technically, you are always using video on the menu.

DVDStyler V-1.31 now supports using either stills or video for the background of the menu. If applying a video clip to the menu, it must be an MPEG clip with both video and audio (elemental streams are not supported on menus)

Creating a menu with video
1. Start a new project and create whatever menus you care to include.
2. Single-left-click on a menu you have on the timeline to give it the focus.
3. Single-left-click on the “Directories” tab (upper left-hand panel). This will display the directory tree.
4. Navigate to the directory that contains your video clips.
5. Double-click on the desired video clip to apply it to your menu. The video file path and filename will be displayed on the menu editing panel.

6. If you want the video to play continuously (loop), access the menu properties (right-click on menu editing panel -> select properties) and change:
   a. Video Object pause to “0”
   b. Menu Post Commands to “jump menu 1;”

7. When the rendered DVD is played, the video clip will be displayed, rather than a still picture.

Using elemental streams

It is difficult to describe an MPEG stream without explaining a long list of the stream components. The whole point of this subject would probably be lost in the details if we were to discuss them all. So, for this section, we will limit the discussion to video and audio components.

**Elemental streams – What is multiplexing?**

Multiplexing is the process of mixing two or more things together into one container. When you bake a cake, you have effectively multiplexed the eggs, butter, flour, and others into one bowl. When a TV signal is broadcasted, the video and audio signals are mixed together (multiplexed) for transmission in a single signal, then they are separated by the electronics in your TV set in order to play them back. In MPEG, you mix video, audio, sub-titles, and other components into one container, sometimes called a cell or video object (VOB), then the DVD player separates the components for playback. The individual components are all strung together in one long stream of pieces.

By multiplexing the components together, the DVD disk can hold dramatically more content than if they were recorded separately. Consider this:

A movie in three languages done separately

Movie in first language = Video component + first language audio component
Movie in second language = Video component + second language audio component
Movie in third language = Video component + third language audio component

Or, multiplexed together:

Movie in all three languages = Video component + first language audio component + second language audio component + third language audio component.
The multiplexed method consumes much less space on the DVD disk. Of course, the duration of the audio tracks have to be exactly matched to the duration of the video tracks, but that issue is the same whether you are multiplexing or not.

Elemental streams – What are the components?

Elemental streams are the parts of the movie clip that make-up the movie. In DVD terminology, a movie clip is called a “title”. Any title can be composed of a combination of various components, all mixed together (multiplexed) in the same file (stream):

1. Video component
   a. Up to one video stream
2. Audio component
   a. Up to eight audio streams
   b. DVDStyler V-1.31 currently supports up to one audio stream per video stream.
   c. DVDStyler V-1.31 currently supports mp2 (mpa), ac3, dts, mp3, and pcm audio formats.
   d. Note – The mp3 audio format is not recommended as most DVD players do not support mp3.
3. Sub-title component
   a. Up to 32 sub-picture streams
   b. Both buttons and sub-titles are made out of sub-pictures.
   c. DVDStyler V-1.31 currently does not support sub-titles.
4. And other components not discussed in this section (NAV packs, PGCs, multiple angles, etc.).

Creating a title with elemental streams

Using elemental streams is very similar to using regular MPEG clips on the timeline. You simply drag the components onto the timeline as you would with MPEG clips (titles).

1. Start a new project and create whatever menus you care to include.
2. Single-left-click on the “Directories” tab (upper left-hand panel) to display the directory tree.
3. Navigate to the directory that contains your video clips (titles).
4. Left-clip-hold-drag the desired video elemental component onto the timeline. The video component will typically have an ".m2v" file extension.
5. Left-clip-hold-drag the desired audio elemental component onto the timeline. The audio component will typically have an ".mpa" file extension.
6. The video and audio component names will be displayed on the information bar below the timeline when the mouse pointer is placed overtop of its icon. It is also displayed on the properties dialog box of the title (right-click on icon -> select properties).
7. Continue to add video/audio or MPEG clips as desired.
Multiple Titlesets

Titlesets – A word of caution

Before diving into the whole concept of titlesets, a word of warning about the subject. You are about to enter the Twilight Zone of DVD. When you make the leap from a simple menu system to fancier designs, the rules, capabilities, and protocol become considerably more complex. You can make very impressive, automated productions with multiple effects, languages and subtitles, but, there is a price to pay. You may find yourself doing an enormous amount of research about the DVD specification and learning a very basic programming language (scripting). With that said, read on.

Titlesets – Why do we need them?

Whether you realized it or not, all DVDs have titlesets, even DVDs with a simple single menu. The latest version of DVDSstyler supports titlesets, but we really mean that it supports multiple titlesets. The primary motivator (that we have found) to using multiple titlesets is in order to provide multiple aspect ratio movies. That means offering movies in standard TV size (4:3) or letterbox size (16:9) on the same DVD disk.

In order for the DVD player to properly render a movie it needs to know certain characteristics of the video it is about to play (aspect ratio, bit-rate, etc). That information comes from the video manager, commonly known as the VMG. In DVDSstyler, the vmMenu is part of the video manager. Here is a list of capabilities that multiple titlesets offers:

1. The ability to create menu systems that have movies of multiple aspect ratios.
2. The ability to create menus that offer multiple languages in the audio track.
3. The ability to create menus that offer sub-titles.
4. The ability to create menus that offer sub-titles in multiple languages.
5. And more that I have not realized yet.
If you do not need to do any of the above, you probably do not need to use the vmMenu selection. DVDStyler V-1.31 currently supports the ability to create menu systems that have movies of multiple aspect ratios (#1 above). The program author plans to support more features in future revisions.

**Titlesets – What are they?**

Generally speaking, a titleset includes one or more of a menu, button, and a title (movie clip). All the titles (movies clips) in a given titleset must be of the same aspect ratio. If you wish to include a title with a different aspect ratio on your DVD, then it must be in a different titleset, and that titleset must be accessed via a video manager menu (VMG menu or vmMenu), which is a special type of menu (more on the vmMenu later).

Also, the navigation between menus, titles, and playing selections may require special instructions (scripting) that customize the playback behavior of the title and menus. This is an example of a simple multiple titleset:

![Diagram of a titleset structure](image)

**Titlesets – A word about aspect ratios**

The shape of your movie (width / height) implies its aspect ratio. TVs are normally considered 4:3. DVD letterbox is 16:9. Movies at the theater are various shapes depending on how they were produced. Here are some examples of various aspect ratios:
If I measure the screen area of my 36-inch Sony TV, it is 28.6 inches wide and 21.5 inches high. So, doing the math:

\[
\frac{29}{21.5} = 1.3302 \quad \text{or, in whole numbers: } (1.3302 \times 3) = 3.9906 \approx 4 / 3,
\]

which is commonly noted as 4:3.

As the movie and TV industries evolved various aspect ratios were used. The DVD specification supports two aspect ratios: 4:3 (standard TV) and 16:9 (letterbox – a good average shape to accommodate wide-screen movies with minimal black bars at the top and bottom of the screen).

**Titlesets – vmMenu versus Menu (or VMG menu versus VTS menu)**

This is where the concept of multiple titlesets starts to become a bit confusing. The rules and capabilities of the menus in the video manager are almost identical to those of the menus in the titleset. So, we need to explain:

**Terminology**
1. The video manager is generally known as the "VMG"
2. The DVD industry calls a menu in the VMG a VMG menu. DVDStyler calls it "vmMenu".
3. The DVD industry calls a menu in the titleset a "VTS menu". DVDStyler calls it a "Menu".

DVDStyler simply calls the two menu types "vmMenu" and "Menu". From this point on, we will use the DVDStyler terminology.

**Guidelines**
4. The video manager (VMG) is not required to include a menu.
5. If the video manager does not have a menu, it will simply jump to the first menu of the first titleset.
6. A "vmMenu" is a menu in the video manager (VMG), not the titleset.
7. A “Menu” is a menu in the titleset, not the video manager.

8. The video manager (VMG) can have multiple menus (vmMenus).
9. If the video manager (VMG) does have a menu (vmMenu):
   a. A vmMenu button can jump to other vmMenus.
   b. A vmMenu button can launch a title (movie clip), but only if it is the first title in its
      associated titleset.
   c. If jumping to a Menu, a vmMenu button can only jump to the first menu in its titleset.
   d. A Menu in a given titleset can jump to other menus in the same titleset.
   e. A Menu in a given titleset cannot jump to other menus in other titlesets.

**Titlesets – The project XML file**

When you save your project an XML file (eXtensible Markup Language) is created. XML is the
syntax used by the DVD player to determine what to do and when to do it. This file is a reflection
of the menu system you have created and can be viewed by opening it with most text editors.
Each command in the file will be “bracketed” with open and close tags, similar to:

1. Typical XML tags
   a. Video Manager menu - `<vmgm>`....`</vmgm>`
   b. Titleset - `<titleset>`....`</titleset>`
   c. Title - `<title>`....`</title>`
   d. Menus - `<menus>`....`</menus>`
   e. Buttons – `<button>`....`</button>`
   f. And many more....

2. The order of the titlesets is determined by their order in the XML file.
3. The file is hierarchical in nature. It encodes -> titleset -> title -> menu -> button. It also
   includes several other items that we will cover in a later section.

**Titlesets – Creating a multi-titleset menu**

It is generally a good idea to try to map out your navigation system before creating menus,
buttons, and jump instructions. This is a typical multi-titleset mapping:
To create the menu system shown above, proceed as follows:

**Create the structure for the first titleset**
1. Start a new project and select the desired resolution (NTSC or PAL). DVDStyler will create the first menu for you.
2. Right-click on the timeline to access the speed menu. Select “vmMenu”.
3. Right-click on the timeline to access the speed menu. Select “Menu”.
4. Important note!!! – Do not add the second titleset to the timeline until the first titleset is configured.
Select the menu background images for the first titleset
1. Single-left-click on the mvMenu to give it the focus.
2. Click on the Backgrounds tab (upper left-hand panel) to display the available menu background images.
3. Double-left-click on the desired menu background image.
4. Return to the timeline and single-left-click on the “Menu 1” to give it the focus.
5. Double-left-click on the desired menu background image.
6. Return to the timeline and single-left-click on the “Menu 2” to give it the focus.
7. Double-left-click on the desired menu background image.

Add titles (clips) to the first titleset
1. Click on the “Directories” tab (upper left-hand panel) to display the directory tree.
2. Navigate to the directory that contains your movie titles (clips).
3. Left-click-hold-drag the desired title to the timeline.
4. Repeat step 3 for each title in the titleset. This example only has a single title in each titleset.

Apply buttons to all the menus of the first titleset
1. Return to the timeline and single-left-click on the “vmMenu” to give it the focus. The vmMenu will be displayed in the menu editing panel (upper right-hand panel).
2. Click on the “Buttons” tab (upper left-hand panel) to display the available buttons.
3. Left-click-hold-drag a button from the “Buttons” panel to the “Menu editing” panel.
4. Repeat step #3 for each button. The vmMenu of this example has two buttons.
5. Return to the timeline and single-left-click on the “Menu 1” to give it the focus. “Menu 1” will be displayed in the menu editing panel (upper right-hand panel).
6. Left-click-hold-drag a button from the “Buttons” panel to the “Menu editing” panel.
7. Repeat step #6 for each button on the menu. “Menu 1” has three buttons.
8. Return to the timeline and single-left-click on the “Menu 2” to give it the focus. “Menu 2” will be displayed in the menu editing panel (upper right-hand panel).
9. Left-click-hold-drag a button from the “Buttons” panel to the “Menu editing” panel.
10. Repeat step #9 for each button on the menu. “Menu 2” has five buttons.
Configure the buttons for the first titleset
1. Return to the timeline and single-left-click on the “vmMenu” to give it the focus. The “vmMenu” will be displayed in the menu editing panel (upper right-hand panel).
2. Double-click on each button of the “vmMenu” and change its properties to:
   a. vmMenu - Button 1 Action – jump titleset 1 menu.
   b. vmMenu - Button 2 Action – jump titleset 2 menu.
   c. Modify the other properties for each button as desired.
3. Return to the timeline and single-left-click on the “Menu 1” to give it the focus. “Menu 1” will be displayed in the menu editing panel (upper right-hand panel).
4. Double-click on each button of the “Menu 1” and change its properties to:
   c. Menu 1 - Button 3 Action – jump vmgm menu.
   d. Modify the other properties for each button as desired.
5. Return to the timeline and single-left-click on the “Menu 2” to give it the focus. “Menu 2” will be displayed in the menu editing panel (upper right-hand panel).
6. Double-click on each button of the “Menu 2” and change its properties to:
   a. Menu 2 - Button 1 Action – jump title 1 chapter 1
   c. Menu 2 - Button 3 Action – jump title 1 chapter N. (as many chapters as desired)
   e. Menu 2 - Button 5 Action – jump vmgm menu.
   f. Modify the other properties for each button as desired.

Add the second titleset
1. Return to the timeline and right-click to display the speed menu. Select “Add” -> “Titleset”.
2. From this point, the steps are basically the same as those for the first titleset, except for the vmMenu. This example only has one vmMenu, but you can add as many as desired. If you
do add more vmMenus, bear in mind that each vmMenu must return through the video manager to access menus of other titlesets (VTSs).

3. Note – When you add a titleset, the container syntax (<titleset> … </titleset>) for the new titleset is added to the XML file. If you wish to remove the added titleset, create a menu for it, and then delete the menu. The new titleset will be deleted from the XML file when you delete the menu. This behavior will probably be changed in a future revision of DVDSstyler.

---

General Notes, Menu Creation Tips, and Known Issues

1. Adding images to the background menu - Menu images displayed in the “Backgrounds” panel come from the “Backgrounds” directory of the DVDSstyler installation directory (this manual uses - C:\Program Files\DVDSstyler\backgrounds). Images may be added to the menu by manually copying graphic files onto that directory. DVDSstyler supports most common graphic formats (JPG, PNG, BMP, etc).

   If you do add images, try to use images that are properly sized for the menu format (PAL – 720 X 576 or NTSC – 720 X 480). DVDSstyler will automatically stretch and resize the
selected image to fit the menu background. See “Advanced Features -> Creating custom images for backgrounds and movie selections” for additional details on creating images.

2. **Creating custom images for backgrounds and movie selections** - Custom images can be created with most graphics editors (not included as part of DVDStyler). A simple method of creating an image is to use MS Powerpoint

   a. Start MS Powerpoint -> Click “File – New”
   b. Delete all titles and heading to get a blank slide.
   c. Change the slide size.
      i. Click File -> Page Setup…
      ii. Change “Slide Sized For” to “Custom”
   d. For PAL menus:
      i. Change “Width:” to 6.25 inches
      ii. Change “Height:” to 5 inches
      iii. 720 / 576 = 1.25 and 6.26 / 5 = 1.25 (same aspect ratio)
   e. For NTSC menus:
      i. Change “Width:” to 7.5 inches
      ii. Change “Height:” to 5 inches
      iii. 720 / 480 = 1.5 and 7.5 / 5 = 1.5 (same aspect ratio)
   f. Add autoshapes, text, and any other desired objects to the slide.
   g. Save the slide to a graphic image by:
      i. Click “File -> Save As…”
      ii. From the “File Save” dialogue box navigate to the desired directory
      iii. Change “Save as type:” to a graphical image type (BMP, JPG, PNG, etc).
      iv. Enter the desired file name.
      v. Click “Save -> Current Slide Only” to save the slide as a graphic file.

3. **Background images** – DVDStyler supports two types of menu images. One is meant to cover the entire menu background and have other objects placed over-top of it. The second is for various images to be placed wherever you care to place them. The following example uses:

   a. Menu background – White filled image (720 X 480) with two red bars.
   b. Movie images – Six images, all sized to 150 X 100 pixels
   c. Image format – Most graphics formats are supported (BMP, JPG, PNG, etc.)
   d. Buttons – Six buttons, one for each movie with text properties modified to suit the button.
   e. Menu heading – Text located at bottom of menu display to label the menu.

   ![Menu Image Example]

   f. There are two methods of selecting a menu background
      i. Double-click on an image on the “Backgrounds” panel, or
      ii. Right-click on the menu editing panel -> Select “Properties” -> Select the “Image” field -> Type-in the full path and filename of the image you wish to use.
iii. If you select a menu background and later wish to remove the image altogether, right-click on the “Menu Editing Panel” -> Select “Properties” -> Select the “Image” field -> blank out the field.

4. **Graphic editing** - XnView is a convenient graphic editing tool (freeware - http://www.xnview.com) used for cropping, resizing, and a myriad other manipulations.

5. **Close video files** - When rendering a project, make sure you do not have a previous iteration of the project open with a DVD viewing program. DVDSstyler will stop rendering until those files are released.

6. **Transparent button** - If you select a background color for a menu button and later decide to change it back to transparent, click the color box next to the color selection button.

![Transparent button](image)

Click here to restore ‘Transparent’ background


8. **Safe –TV region** – Some users have commented on the “Safe-TV” region for the menu content.

Excerpt:
Unlike computers, most TVs do not show the complete 720 X 576 (in PAL) pixels. My suggestion is to have 40 pixel borders (left and right), and 32 pixels borders (top and bottom) to have a 640 X 512 safe TV area.

This is a good suggestion. Try to keep all of your menu content slightly inside of the menu editing area, as the TV will tend to cut-off some of the outer edges.

9. **Additional audio information**
   a. Dolby Digital
      i. Format - ac3
      ii. 1 to 5.1 channels
      ii. Uses PCM source
   b. PCM - Supports 1 to 8 channels.
   c. Optional DVD format – DTS (Digital Theater Systems)
   d. Optional DVD format - SDDS (Sony Dynamic Digital Sound)
   e. PDM – Pulse Density Modulation
   f. SDDS - Sony Dynamic Digital Sound
   g. The ".1" in 5.1 or 7.1 refers to a low-frequency effect (LFE) channel that connects to a subwoofer. This channel carries an emphasized bass audio signal.
   h. Audio CD is limited to 44.1 kHz at 16 bits
   i. It's generally felt that the 120 dB dynamic range of 20 bits combined with a frequency response of around 22,000 Hz from 48 kHz sampling is adequate for high-fidelity sound reproduction
   j. Dolby Digital is multi-channel digital audio, using lossy AC-3 coding technology from PCM source with a sample rate of 48 kHz at up to 24 bits
k. Dolby Digital is the format used for audio tracks on almost all DVDs.

l. MPEG audio is multi-channel digital audio, using lossy compression from original PCM format with sample rate of 48 kHz at 16 or 20 bits.

m. In PCM, the variable bit rate is 32 kbps to 912 kbps, with 384 being the normal average rate.

n. Channel combinations are (front/surround): 1/0, 2/0, 2/1, 2/2, 3/0, 3/1, 3/2, and 5/2. The LFE channel is optional with all combinations. The 7.1 channel format adds left-center and right-center channels, but is rare for home use.

o. MPEG Layer 3 (MP3) and MPEG-2 AAC (also known as NBC or unmatrix) are not supported by the DVD-Video standard.

p. DTS (Digital Theater Systems) Digital Surround is an optional multi-channel digital audio format, using lossy compression from PCM at 48 kHz at up to 24 bits.

q. SDDS (Sony Dynamic Digital Sound) is an optional multi-channel (5.1 or 7.1) digital audio format, compressed from PCM at 48 kHz. Sony has not announced any plans to support SDDS on DVD.

r. THX (Tomlinson Holman Experiment) is not an audio format. It’s a certification and quality control program that applies to sound systems and acoustics in theaters, home equipment, and digital mastering processes.

s. Discs containing 525/60 (NTSC) video must use PCM or Dolby Digital on at least one track. Discs containing 625/50 (PAL/SECAM) video must use PCM or MPEG audio or Dolby Digital on at least one track.

t. Dolby Digital dynamic range compression (DRC) feature, often called midnight mode

u. The Dolby Digital dynamic range compression (DRC) feature, often called midnight mode, reduces the difference between loud and soft sounds so that you can turn the volume down to avoid disturbing others yet still hear the detail of quiet passages. Some players have the option to turn off DRC.

v. Dolby Digital also includes a feature called dialog normalization (DN), which should more accurately be called volume standardization. DN is designed to keep the sound level the same when switching between different sources.

w. Only one menu has the entry="root" attribute. This is the one that will be displayed if you press the "Menu" button on your remote or hit Escape in xine.

x. Even a static menu background is converted into a very short movie clip for the purpose of displaying its contents. Menus are actually very short titles

10. Known issues

a. The “Burn” selection from the “Burn” menu is currently supported in the Linux distribution only. This feature is planned for the Windows distribution in a future version.

b. At the time of this writing, the program has been shown to operate well on Windows-2000 and Windows-XP. It does not however do well with Windows-98. The developer(s) are currently attempting to resolve those issues.

c. Log directory - This “Log” field (from Configuration -> Setting) is for future use. Logged messages are currently not supported. If you do enter a file name into this field, it must be a valid location and file name (i.e. "C:\Program Files\DVDStyler\Log\MyLog.txt" will work, "C:\Program Files\DVDStyler\Log" will cause an error in the rendering process).

d. Saving your project – Earlier versions of DVDSstyler did not support all “Property” saving functions when saving the menu project (File -> Save as). The developers believe this issue has been resolved (testing incomplete) but your may wish to do all menu creation, editing, and final rendering during the same session.

e. Custom colors do not stay in the custom color grid after restarting the program. This issue will be resolved in a future version.
Playing music during menu display is planned for a future version.

Rendered movies might not play properly in WinDvd. Clicking and un-clicking the “Zoom” button seems clear it up.

Having other programs active on the desktop sometimes makes the program-focus of DVDStyler misbehave (render -> switch to another application -> return to DVDStyler and render another movie -> focus is not always restored to DVDStyler when rendering completes). Solve this by minimizing all other programs prior to rendering.

Authors and links
DVDStyler program author – Alex Thuering <alex.thuering@web.de>
DVDStyler documentation author – Don Brett <dlbrett@zoominternet.net>

Translations:
- Catalan   - Miguel <ca@openlang.net>
- French   - Philippe Martin <phil.martins@laposte.net>
- German   - Alex Thuering <alex.thuering@web.de>
- Hungarian - Faczan Laszlo <faczan@freemail.hu>
- Italian   - Roberto Minotti <khazard-dum@mail.orson.it>
- Polish    - Michał Jusyk <drewnozlasu@o2.pl>
- Portuguese - Henrique Lopes barone_henrique@yahoo.com.br
- Portuguese (Brazilian) - Marco de Freitas
- Russian   - Alex Thuering <alex.thuering@web.de>
- Spanish   - Redy Rodriguez redy@telefonica.net
- Serbian   - CICIC Ivana
- Japanese  - Montty
- Basque    - Piarres Beobide

Libraries and Tools
- wxWidgets - Julian Smart, Robert Roebling and others
- DvdAuthor - Scott Smith
- mjpegt tools - Rainer Johanni, Gernot Ziegler and others
- mpgtx     - Laurent Alacoque
- cdrtools   - Joerg Shilling
- dvd+rw-tools - Andy Polyakov

Packagers
- Debian   - Juergen Braun <jaybe@sourceforge.net>

General
- Wiki Developer - Richard Spindler
- New Button Dialog - Richard Spindler
- Additional Backgrounds - Henrique Lopes

DVDStyler program home page - http://dvdstyler.sourceforge.net/
DVDStyler SourceForge link - https://sourceforge.net/projects/dvdstyler/
DVD Demystified (compliments of Jim Taylor) - http://www.dvddemystified.com/dvdfaq.html